problems with installing

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

problems with installing

Koenr
Hi, I am writing you because I experience problems with installing graph-tool

I do what was said in
https://git.skewed.de/count0/graph-tool/-/wikis/installation-instructions#debian-ubuntu 

I get following error:
-------------------------------------------------------------------------------------------------------------------
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python3-graph-tool : Depends: libboost-regex1.71.0-icu67 but it is not
installable
                      Recommends: libgv-python but it is not installable
                      Recommends: python-matplotlib but it is not
installable
                      Recommends: python-cairo but it is not going to be
installed
                      Recommends: python-gi-cairo but it is not going to be
installed
                      Recommends: python-gi but it is not going to be
installed
E: Unable to correct problems, you have held broken packages.
-------------------------------------------------------------------------------------------------
I added the following line to sources.list

deb https://downloads.skewed.de/apt bullseye main

Can you help with this? I use ubuntu within Windows






--
Sent from: https://nabble.skewed.de/
_______________________________________________
graph-tool mailing list
[hidden email]
https://lists.skewed.de/mailman/listinfo/graph-tool
Reply | Threaded
Open this post in threaded view
|

Re: problems with installing

Tiago Peixoto
Administrator
Am 15.11.20 um 18:54 schrieb Koenr:
> I added the following line to sources.list
>
> deb https://downloads.skewed.de/apt bullseye main
>
> Can you help with this? I use ubuntu within Windows

But bullseye is a Debian release, not Ubuntu. Replace it with your
Ubuntu release name and it will work.

Best,
Tiago

--
Tiago de Paula Peixoto <[hidden email]>


_______________________________________________
graph-tool mailing list
[hidden email]
https://lists.skewed.de/mailman/listinfo/graph-tool

signature.asc (849 bytes) Download Attachment
--
Tiago de Paula Peixoto <tiago@skewed.de>