Unable to install on ubuntu 16.04 LTS

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Unable to install on ubuntu 16.04 LTS

dexterd
Hi, I followed the instructions in the official website
(https://git.skewed.de/count0/graph-tool/-/wikis/installation-instructions#debian-ubuntu)
to install graph-tool on ubuntu 16.04 LTS. I set DISTRIBUTION to xenial
(corresponding to ubuntu 16.04 LTS). Then I downloaded the public key as
instructed. However, when I ran apt-get update, it reported the error:
"The repository 'https://downloads.skewed.de/apt xenial Release' does not
have a Release file". The following line would not work, neither.
I wonder which DISTRIBUTION should I set? I tried the ones listed in the
website but failed when executing the "apt-get install
python3-graph-tool"...

Thank you very much for your time and I look forward to you reply.




--
Sent from: https://nabble.skewed.de/
_______________________________________________
graph-tool mailing list
[hidden email]
https://lists.skewed.de/mailman/listinfo/graph-tool
Reply | Threaded
Open this post in threaded view
|

Re: Unable to install on ubuntu 16.04 LTS

Tiago Peixoto
Administrator
Am 30.06.20 um 11:25 schrieb dexterd:

> Hi, I followed the instructions in the official website
> (https://git.skewed.de/count0/graph-tool/-/wikis/installation-instructions#debian-ubuntu)
> to install graph-tool on ubuntu 16.04 LTS. I set DISTRIBUTION to xenial
> (corresponding to ubuntu 16.04 LTS). Then I downloaded the public key as
> instructed. However, when I ran apt-get update, it reported the error:
> "The repository 'https://downloads.skewed.de/apt xenial Release' does not
> have a Release file". The following line would not work, neither.
> I wonder which DISTRIBUTION should I set? I tried the ones listed in the
> website but failed when executing the "apt-get install
> python3-graph-tool"...
>
> Thank you very much for your time and I look forward to you reply.
There are no packages for xenial, since it's outdated and has reached
end of life. You should upgrade to a supported ubuntu version (the
current LTS is 20.04, but 18.04 will work too).

--
Tiago de Paula Peixoto <[hidden email]>


_______________________________________________
graph-tool mailing list
[hidden email]
https://lists.skewed.de/mailman/listinfo/graph-tool

signature.asc (849 bytes) Download Attachment
--
Tiago de Paula Peixoto <tiago@skewed.de>
Reply | Threaded
Open this post in threaded view
|

Re: Unable to install on ubuntu 16.04 LTS

Tiago Peixoto
Administrator
Am 30.06.20 um 12:32 schrieb Tiago de Paula Peixoto:
> There are no packages for xenial, since it's outdated and has reached
> end of life. You should upgrade to a supported ubuntu version (the
> current LTS is 20.04, but 18.04 will work too).

I'm sorry, this is incorrect, xenial has not reached end of life. It's
just too old to compile graph-tool.

Best,
Tiago

--
Tiago de Paula Peixoto <[hidden email]>


_______________________________________________
graph-tool mailing list
[hidden email]
https://lists.skewed.de/mailman/listinfo/graph-tool

signature.asc (849 bytes) Download Attachment
--
Tiago de Paula Peixoto <tiago@skewed.de>