Problems compiling graph-tool

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Problems compiling graph-tool

aitor
Hello,

i'm trying to compile the graph-tool package in my ubuntu dapper box. I
have gcc 4.0.3 and the boost libraries (1.33.1).

When compiling the program i receive an error attached to this mail. I
think it has something to do with tr1::hashtable, but sincerely i have
no cue.

Any thoughs ?

Thank you and regards

                                aitor

ll.txt (11K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Problems compiling graph-tool

Tiago de Paula Peixoto
On 10/11/2006 03:26 AM, aitor wrote:

> Hello,
>
> i'm trying to compile the graph-tool package in my ubuntu dapper box. I
> have gcc 4.0.3 and the boost libraries (1.33.1).
>
> When compiling the program i receive an error attached to this mail. I
> think it has something to do with tr1::hashtable, but sincerely i have
> no cue.
>
> Any thoughs ?
You need GCC 4.1 or above to compile graph-tool, exactly because of tr1
modifications. Alternatively, you can just provide the headers for the
tr1 code included in GCC 4.1, and use GCC 4.0. I'm sending the headers
attached. You can compile with these headers by doing:

$ CXXFLAGS="-I/extraction/path/" ./configure
$ make

where "/extraction/path" is the full path where you extracted the
tr1.tar.gz archive.

But just installing GCC 4.1.1 may be easier... And you get a new
compiler in the process. :-)

Take care.
--
Tiago de Paula Peixoto <[hidden email]>

tr1.tar.gz (57K) Download Attachment
signature.asc (307 bytes) Download Attachment