Problem installing graph-tools

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem installing graph-tools

Daniela Saban
Hi! I am trying to install graph tools and i ran out of ram while the "make" process is taking place (even though i have 2gb ram and 1gb swap).
I tried the option --disable-visibility while i ran configure, but it did not helped. If i try the precompiled packages, this is what i get:

arti@estanque:~/Desktop/graph-tool-1.1.2-precompiled-x86_64$ ./graph-tool
Traceback (most recent call last):
  File "./graph-tool", line 24, in <module>
    from libgraph_tool import *
ImportError: /home/arti/Desktop/graph-tool-1.1.2-precompiled-x86_64/libgraph_tool.so: undefined symbol: _ZNSs4_Rep20_S_empty_rep_storageE


arti@estanque:~/Desktop/graph-tool-1.1.2-precompiled-i686-static$ ./graph-tool
Traceback (most recent call last):
  File "./graph-tool", line 24, in <module>
    from libgraph_tool import *
ImportError: /home/arti/Desktop/graph-tool-1.1.2-precompiled-i686-static/libgraph_tool.so: wrong ELF class: ELFCLASS32

My system details are:
Python 2.5.1 (r251:54863, Oct  5 2007, 13:50:07)
[GCC 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)] on linux2
boost 1.34.1
expat /libexpat 1.95.8

I will really like to have the tool installed. Any ideas of how i can make it work? Thank you very much, Daniela.
Reply | Threaded
Open this post in threaded view
|

Re: Problem installing graph-tools

Tiago de Paula Peixoto
Hi Daniela,

On 01/21/2008 06:30 PM, Daniela Saban wrote:
> Hi! I am trying to install graph tools and i ran out of ram while the
> "make" process is taking place (even though i have 2gb ram and 1gb
> swap).  I tried the option --disable-visibility while i ran configure,
> but it did not helped. If i try the precompiled packages, this is what
> i get:
>

[...]

> ImportError:
> /home/arti/Desktop/graph-tool-1.1.2-precompiled-x86_64/libgraph_tool.so:
> undefined symbol: _ZNSs4_Rep20_S_empty_rep_storageE
>

[...]

> My system details are:
> Python 2.5.1 (r251:54863, Oct  5 2007, 13:50:07)
> [GCC 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)] on linux2
> boost 1.34.1
> expat /libexpat 1.95.8
>
> I will really like to have the tool installed. Any ideas of how i can
> make it work? Thank you very much, Daniela.

The precompiled binaries don't work because they were compiled using a
different GCC version. It looks like you're in a 64 bit architecture,
correct? Unfortunately GCC seems to need more memory when compiling for
64 bit systems... I think you should try to upgrade your GCC to version
4.2.2, since it seems to be lighter on memory usage. I was able to
compile it under 2 GB on a 64 bit system using that GCC version...

I hope this helps.

Best regards,
Tiago

--
Tiago de Paula Peixoto <[hidden email]>


signature.asc (370 bytes) Download Attachment